Pregunta Smartgit y Windows 8.1 - La integración del menú contextual no funciona


The file does not have a program associated with it for performing this action. ... 

El mensaje de error habitual. He instalado shmnview (por Nirsoft), y verificó la entrada del menú de contexto.
"C:\Program Files (x86)\SmartGit\bin\smartgit.exe" "-open" "%1" 

Si copio el comando en Win+R, funciona perfecto Abre el directorio que doy.

Regkey se ve así:
- Ordenador \ HKEY_CLASSES_ROOT \ Directory \ shell \ smartgit \ command
- La carpeta Smartgit tiene un (default) valor, diciendo "Abrir en Smartgit"
- command carpeta debajo tiene otro (default) valor con el comando que pegué arriba.

Entonces, ¿cómo se produce un error con Explorer, haga clic derecho?


1


origen




Respuestas:


No sé si ya obtuvo una solución, pero tuve el mismo problema y lo resolví con las siguientes entradas de registro:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\smartgit]
@="Open in SmartGit"

[HKEY_CLASSES_ROOT\Directory\shell\smartgit\command]
@="\"C:\\Program Files (x86)\\SmartGit\\bin\\smartgit.exe\" --open \"%V\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\background\shell\smartgit]
@="Open in SmartGit"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\background\shell\smartgit\command]
@="\"C:\\Program Files (x86)\\SmartGit\\bin\\smartgit.exe\" --open \"%V\""

Simplemente cópielo y péguelo en un archivo de texto, asígnele el nombre que desee, pero con la extensión de nombre de archivo ".reg" y ejecútelo. Reinicie explorer.exe y debería funcionar.


3



Una explicación más detallada de su cambio de registro mejoraría la respuesta - Dave M


Mi registro ya tenía las entradas anteriores, mi problema era UX. Debe seleccionar una carpeta en el Explorador para abrir en SmartGit: haga clic derecho en el espacio vacío en el panel derecho y haga clic en "Abrir en Smartgit" arroja el error.


0