Pregunta El idioma del teclado cambia constantemente en Windows 10


Así que recientemente hice una instalación limpia de Windows 10 en inglés. Lo configuré para que tuviera el idioma de la interfaz de usuario en inglés, pero el teclado noruego. Tengo varios problemas con esa configuración:

  1. El idioma del teclado cambia constantemente al inglés
  2. No puedo ver la barra de idioma ni el idioma alternar entre ventanas emergentes cuando cambio:

    language toggle popup

He vinculado el diseño de teclado noruego a Cambio+Alt+0 y eso funciona, pero es molesto tener que hacer eso cada 5 minutos. También me parece raro que no pueda ver la barra de idioma ni en el escritorio ni en la barra de herramientas.

Alguien tiene alguna idea de lo que podría estar mal?

Aquí hay algunas capturas de pantalla de mi configuración:

settings 1

settings 2

settings 3

No language bar on the toolbar

PD La única vez que veo el menú emergente de alternar idioma es cuando cierro la sesión en la pantalla de bloqueo y presiono Ganar+Espacio. No pasa nada si lo hago después de haber iniciado sesión.


230


origen


Esto me ha llevado a UP THE WALL desde que instalé Windows 10. La distribución del teclado cambia esporádicamente a medida que escribo. Juro que no toqué el atajo <kbd> Ganar </ kbd> + <kbd> Espacio </ kbd>. - Colonel Panic
Alt + Shift también cambia el idioma que parece. - Mir
Y Left Ctrl + Shift cambia teclados si hay más de un teclado instalado !! Alt + Shift y Ctrl + Shift son patrones de acceso directo comunes en Code Editors y productos de Adobe (Photoshop, por ejemplo). WINDOWS-: ¡Esa fue una elección pobre e innecesaria de secuestro de acceso directo! Qué verguenza. ¡Decir ah! ¡No es de extrañar que tuviera que seguir "reiniciando"! ¡Pensé que esta nueva computadora portátil / teclado estaba rota! Gracias a todos por la Solución :) - SherylHohman
Me entristece que MSFT todavía tenga tales problemas básicos de usabilidad. - Bruno Brant


Respuestas:


En Windows 10, de forma predeterminada, presionando CTRL+CAMBIO (o para algunos ALT+CAMBIO - gracias madmenyo) recorrerá los diseños de teclado que haya mapeado y es sorprendentemente fácil hacerlo por error.

Si sigues presionando CTRL+CAMBIO (o lo que sea que lo haya cambiado), entonces pronto debe volver a la configuración correcta. (alternativamente reiniciar que es lo que hice la primera vez ;-))

Puede desactivar esta acción predeterminada del teclado de la siguiente manera:

Control Panel > Clock, Language, and Region > Language > Advanced settings > Switching input methods > Change language bar hotkeys > Change key sequence... > Switch keyboard layout > Not Assigned

a partir de 2016, la ubicación ha cambiado. (de los comentarios)

Control panel > Language > Advanced settings > Switching input methods > Change language bar hot keys 

Tenga en cuenta que lo anterior no siempre funciona: los reinicios y el modo de suspensión pueden cambiar el teclado predeterminado (generalmente a EE. UU.). No he encontrado una solución de hierro fundido aunque la creación de un nuevo perfil puede ayudar, aunque no es una respuesta particularmente satisfactoria en mi humilde opinión .

En una emergencia

WIN+R  
osk

para que aparezca el Teclado en pantalla podría ayudar temporalmente.

También tenga en cuenta que es posible desactivar esto para que ninguna combinación de teclas cambie el idioma - cambie las teclas a "No asignado" - vea la respuesta a continuación de Mort para obtener más información


314



Whaaaat. Uso Ctrl + Shift con frecuencia en Visual Studio. No es de extrañar que mi distribución de teclado haya cambiado constantemente. ¡Gracias! - willem
Para mí esto es en realidad ALT+SHIFT - Madmenyo
Impar. Tal vez cambiaron eso, pero para mí dice que el atajo para cambiar es [tecla de Windows] + [espacio], lo que parece un poco más razonable (y de hecho parece ser lo único que funciona como atajo de cambio de idioma). - Nyerguds
Para cualquier persona que venga a esto en 2016, parece que la ubicación ha cambiado. Ahora está ubicado en Control panel//Language//Advanced settings//Switching input methods//Change language bar hot keys - David Metcalfe
ser precisamente: win + space cambios entre todos los pares configurados de idioma / teclado. alt + shiftsolo cambia el idioma y ctrl + shift solo cambia el teclado - Simon Zyx


Si hace clic en el enlace "Cambiar las teclas de acceso rápido de la barra de idioma", visible en su última captura de pantalla, debería poder ver qué teclas están destinadas a cambiar el idioma del teclado.

La configuración predeterminada es muy fácil de usar, al usar el teclado, lo que cambia repentinamente el idioma del teclado. Cambiar las teclas a "No asignado" evitará que el idioma del teclado se cambie accidentalmente.


15



Sí, esos fueron configurados a Shift + Alt originalmente y luego los cambié a "ninguno". Desafortunadamente eso no resolvió el problema solo, pero mira mi otra respuesta. - Nilzor


Resulta que tuve que configurar un diseño de teclado en la primera captura de pantalla. Notarás que dice "Teclado: no disponible". Entonces haga clic en "Opciones" aquí, luego "Agregar un método de entrada" y luego seleccione QWERTY. Norwegian resolvió el caso.

No sé cómo pude instalar Windows con una configuración de lenguaje tan borked. De todos modos, les aconsejo a todos que observen más de cerca las preguntas sobre el idioma en la instalación inicial.

Pic1

Pic2


12



Después de intentar que la escritura a mano funcionara en francés (en Canadá) tuve instaladas 2 versiones de inglés (EE. UU., Canadá) y francés (Francia, Canadá), sin mencionar más de un método de entrada para el inglés de EE. UU. En resumen, esta respuesta me permitió limpiar todo eso muy bien. - Fuhrmanator


La configuración de registro directo para deshabilitar la distribución de teclado alternar teclas de acceso rápido es:

reg add "HKCU\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3

Es posible que también desee

reg add "HKCU\Keyboard Layout\Toggle" /v "Language Hotkey" /d 3
reg add "HKCU\Keyboard Layout\Toggle" /v "Hotkey" /d 3

Y para usuarios nuevos, intente esto (en un mensaje elevado):

reg load HKEY_USERS\temp "%USERPROFILE%\..\Default\NTUSER.DAT"
reg add "HKEY_USERS\temp\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3
reg unload HKEY_USERS\temp

9



¿Qué están haciendo estos comandos? - kleinfreund
@kleinfreund Como se menciona en la primera oración, deshabilita los atajos de teclado que alternan el diseño, por lo que no se puede cambiar inadvertidamente. - mivk
¡Gracias! Ejecutar una construcción interna y eliminaron por completo la sección de idioma del Panel de control. Todavía no puedo entender qué llevó a Microsoft a usar un combo de teclas tan común. - samdd
¡Gracias! La única forma en que funciona en 2018 para bloquear el cambio de alt-shift / ctrl-shift, parece que el componente de UI donde podrías cambiarlo ya no está, no puedo encontrarlo en ningún lado. - jakub.g


Solución1

usa esta solución- ¿Cómo deshabilitar el cambio automático del diseño del teclado en Windows 8? 

Solution2

Elija el segundo idioma como predeterminado. luego, cuando cambies a la primera, permanecerá conmutada.

(gracias a @SimonSeyock):

win + space cambios entre todos los pares de idiomas / teclado.  
alt + shift  solo cambia de idioma  
ctrl + shift solo cambia el teclado


5



Solution 1 en realidad no ofrece una solución en ese enlace. Eso resuelve una método de entrada no es un lenguaje de entrada. - msysmilu
alt + shift lo hizo por mí. Nada más realmente funcionó - Ghoti and Chips


Mi problema: tengo 3 idiomas (diseños de teclado) instalados. Cuando se va a dormir en Windows 10 y luego se despierta, siempre vuelve al "idioma principal", en lugar de mantener el último establecido. Considero esto un error.

Solución:

  1. Abierto Control Panel\All Control Panel Items\Language.
  2. Haga clic en Advanced Settings.
  3. Debajo Switching input methods, comprobar el Let me set a different input method for each app windows.

Esto mantendrá el idioma cuando vaya a dormir y regrese.


5



Gracias. Esto resolvió mi problema con el diseño del teclado siempre cambiando de nuevo a "predeterminado" después de reiniciar y después de dormir. También tengo 3 diseños de teclado instalados. Inglés, porque funciona mejor con algunos juegos y dos suecos. Qwerty normal y dvorak. - Albert Veli
Tuve un problema similar, lo resolví definiendo mi teclado directamente debajo del idioma principal: ver superuser.com/a/1322521/97570 - jakub.g


2018 respuesta:

Tuve el mismo problema al tratar de usar el teclado polaco con el idioma de la interfaz de usuario en inglés de Windows.

Cada vez que cerré la computadora, volvió al teclado de EE. UU.

El problema era que tenía un teclado polaco en polaco, donde, de hecho, lo que realmente quería era un teclado polaco en inglés.

Eliminé el paquete de idioma polaco, agregué el teclado polaco al idioma inglés y eliminé el teclado estadounidense del idioma inglés. Consulte la captura de pantalla a continuación:

Windows 10 (2018) language preferences

En resumen, el truco consiste en agregar el teclado deseado como único teclado en el idioma predeterminado.

(Esto funciona para mí porque generalmente escribo en inglés, solo que algunas veces quiero ingresar en polaco, pero puedo hacerlo sin cambiar el teclado, ya que el teclado polaco es totalmente compatible con US QWERTY).


4