Pregunta OpenVPN luchando


Tengo algunos problemas con mi configuración de OpenVPN.

La puesta en marcha: -> Ubuntu Server 12.04 -> Dos NIC activas: eth0 (predeterminado): 192.168.1.0/24 eth1: x.x.x.x (ip externa)

Logré hacer funcionar la ruta para poder conectarme al mundo exterior con la NIC eth1.

holmen@filserver:~$ ping -I eth1 -c 3 www.linuxquestions.org
PING www.linuxquestions.org (75.126.162.205) from 192.168.1.2 eth1: 56(84) bytes of data.
64 bytes from www.linuxquestions.org (75.126.162.205): icmp_req=1 ttl=50 time=133 ms
64 bytes from www.linuxquestions.org (75.126.162.205): icmp_req=2 ttl=50 time=133 ms
64 bytes from www.linuxquestions.org (75.126.162.205): icmp_req=3 ttl=50 time=133 ms

--- www.linuxquestions.org ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 133.281/133.336/133.379/0.423 ms
One curious thing is that the "from ip #". It says "from 192.168.1.2 eth1" but that ip is the servers ip on the eth0 iface.

Netstat:

holmen@filserver:~$ netstat -anr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0
x.x.x.x     0.0.0.0         255.255.128.0   U         0 0          0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0

Pero aquí viene el problema real: Cuando se configura openvpn con la opción "local x.x.x.x (eth1 ext ip)", aún se tuneliza la interfaz eth0. Y no puedo entender por qué.

Configuración de OpenVPN:

client

dev tap

proto udp

local x.x.x.x

remote openvpn.anonine.net 1194
remote openvpn.anonine.net 1195
remote openvpn-2.anonine.net 1196
remote openvpn-2.anonine.net 1197
remote openvpn-3.anonine.net 1198
remote openvpn-3.anonine.net 1199
remote openvpn-4.anonine.net 1200
remote openvpn-4.anonine.net 1201

remote-random

resolv-retry infinite

auth-user-pass

persist-key
persist-tun

ca anonine.ca.crt

ns-cert-type server

comp-lzo

reneg-sec 0

verb 3

Netstat (túnel activo):

holmen@filserver:~$ netstat -anr
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         46.246.20.129   128.0.0.0       UG        0 0          0 tap0
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0
5.150.128.0     0.0.0.0         255.255.128.0   U         0 0          0 eth1
46.246.20.128   0.0.0.0         255.255.255.128 U         0 0          0 tap0
80.67.8.222     192.168.1.1     255.255.255.255 UGH       0 0          0 eth0
128.0.0.0       46.246.20.129   128.0.0.0       UG        0 0          0 tap0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0

¿Alguien tiene alguna idea?


0


origen




Respuestas:


Tu netstat muestra que el Proveedor de servidor VPN está redirigiendo la puerta de enlace de su cliente (que es una práctica estándar para Servicios VPN anonimizadores) Esto significa que va a hacer un túnel todas tráfico, independientemente de qué interfaz sea la fuente. Lo que necesitas es route-nopull en su configuración de cliente, lo que detendrá al servidor cambiando su tabla de enrutamiento, permitiéndole crear manualmente las rutas que necesita.


1





Si te entiendo correctamente, quieres que los clientes de OpenVPN sigan una determinada ruta, ¿correcto? Si es así, intente agregarlo a la configuración del servidor. He incluido la configuración del servidor de uno de mis laboratorios de prueba a continuación, agregué el local <ext eth1 ip> a la configuración del servidor:

local xxx.xxx.xxx.xxx
port 443
proto tcp
dev tap1
ca cacert.pem
cert servercert.pem
key servercert-unencr.key
dh dh1024.pem
persist-key
persist-tun
keepalive 20 120
tun-mtu 1500
server-bridge 192.168.200.1 255.255.255.0 192.168.200.10 192.168.200.15
ifconfig-pool-persist ipp-generic.txt
comp-lzo
duplicate-cn
daemon
verb 3
#redirect-gateway def1
push "route 192.168.100.0 255.255.255.0"
log-append /etc/openvpn/logs/ovpn-generic.log
up /etc/openvpn/ifconfig-tap1.sh
cd /etc/openvpn
push "dhcp-option DOMAIN lab.test"
push "dhcp-option NBT 2"
push "dhcp-option DNS 192.168.100.1"
push "dhcp-option DNS 4.2.2.2"
script-security 3 system

Voy a actualizar si tienes preguntas.

ACTUALIZAR: Tiene una entrada en su tabla de enrutamiento que apunta todo su tráfico a través de su interfaz eth0:

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

Eso debería cambiarse a eth1 Iface y eth1La IP de la puerta de enlace se eliminó por completo ya que ya tiene una ruta para su red local y está en conflicto con su otra ruta predeterminada:

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         46.246.20.129   128.0.0.0       UG        0 0          0 tap0

Mi conjetura es que el destino es el mismo, pero la segunda entrada tiene prioridad.


1



No soy el que aloja el servidor ya que es un servicio de anonimato. - junkyhlm
¿Entonces la máquina Ubuntu que mencionaste anteriormente no es el servidor OpenVPN, sino el cliente OpenVPN? - MDMoore313
Eso es correcto. Estoy tratando de conectarme al anonimizador. - junkyhlm