Pregunta Sonido Raspberry Pi


Estoy tratando de configurar el festival de software de Linux, que convierte texto en voz en una Raspberry Pi.

Antes y después de que se reproduce el sonido, se escucha un sonido de falla.

¿Alguien sabe qué está causando este ruido anormal?

¿Cómo puedo deshacerme de esto?

Parece que es la Raspberry Pi la que está causando el problema, porque tengo el mismo problema con el espeak.

¿Sería mejor usar HDMI?

Este tipo tiene el mismo sonido de falla cuando está reproduciendo sonidos. Reenviar a 3:18 en el video. http://www.youtube.com/watch?v=br-xyW8iccg&feature=fvsr


0


origen


No sé por qué me merecía el voto negativo por tener un problema. - user1728363
el conector de audio en el Pi es horrible. necesita usar HDMI o una tarjeta de sonido USB para hacerlo soportable. - Dale Johnson


Respuestas:


De acuerdo, después de escuchar el sonido en el video, parece ser un problema general con la Raspberry Pi.

Solo dejo esto aquí para la referencia del video en los comentarios.

Bueno, esto solo estoy adivinando sin escuchar el ruido. Pero sé por los programas de estación de trabajo de audio digital que siempre se desvanecen en el sonido cuando comienzan con un archivo de muestra o de onda y desaparecen cuando terminan con eso. Supongo que tu texto a voz genera o ensambla estos sonidos. Cuando se cambia de un archivo a otro y hay un nivel de CC estático o diferente en estos archivos (o los sonidos generados), esto podría generar algo de ruido. Estas son solo algunas puñaladas al azar sin saber más detalles.


1



Si miras este video Este tipo está haciendo lo que me gustaría hacer y tiene el mismo sonido de falla. Remita a 3:18 en el video y escuche: youtube.com/watch?v=br-xyW8iccg&feature=fvsr - user1728363
Obtengo el mismo sonido de fallo cuando reproduzco un archivo wav con el software aplay linux. - user1728363


Leí en otro foro que podría ser la frecuencia de muestreo que causó el problema. Intenté reproducir un archivo wav normal, pero tuve el mismo ruido antes y después.

La única solución al problema que he encontrado es usar HDMI. No se escucha ningún ruido entonces.

En este sitio, el autor escribe que el controlador de sonido para Raspberry Pi todavía está en una versión beta, así que con suerte el problema se solucionará con una versión posterior.

http://mitchtech.net/raspberry-pi-audio/

También encontré esto que puede ser de ayuda. https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#Pops_When_Starting_and_Stopping_Playback

https://raspberrypi.stackexchange.com/questions/3626/how-to-get-better-audio-quality-from-audio-jack-output


1



El problema se solucionó actualizando el software Raspbian. Obviamente había un error en la versión que estaba ejecutando. - user1728363