Pregunta ¿WSL ahora está disponible en LTSB?


Como se documenta aquí y en otros lugares, el subsistema de Windows para Linux se encuentra actualmente en versión beta y, por lo tanto, no está disponible en la rama de servicio a largo plazo de Windows 10. Mi experiencia en LTSB es que puedes habilitar la función WSL, pero Windows Store no descargaría la aplicación de distribución.

Hace unos días noté un MS cómo comenzar:

"Hay varios escenarios en los que es posible que no pueda (o desee) instalar las distribuciones de WSL Linux a través de la Tienda Windows. Específicamente, puede estar ejecutando una Windows Server o SKU de escritorio del sistema operativo de escritorio a largo plazo (LTSB / LTSC) que no es compatible con la Tienda Windows o las políticas y / o administradores de su red corporativa para no permitir el uso de la Tienda Windows en su entorno.

En estos casos, mientras WSL está disponible, ¿cómo descargas e instalas las distribuciones de Linux en WSL si no puedes acceder a la tienda?

https://docs.microsoft.com/en-us/windows/wsl/install-manual

Esto me llevó a pensar que WSL estaría disponible en LTSB. Sin embargo, encuentro el mismo error de "versión no compatible" cuando intento instalar el paquete. También el MS howto doc parece un poco apresurado (enlaces defectuosos, errores de ortografía y gramática), así que no sé cuánto stock poner en él.


0


origen


WSL, ya no es una función de Windows beta, no ha sido durante casi un año - Ramhound
Según la versión o la política de red, es posible que las máquinas con Windows no puedan acceder a la Tienda Windows. Por ejemplo, según el sitio web de MS, algunos Windows LTSB pueden instalar la función WSL pero no pueden acceder a la Tienda Windows. - Jaime
@Ramhound Bueno, que actualmente no sea beta no es particularmente relevante. Era beta en el momento de la última actualización de LTSB. - Hasse1987
@Jaime ¿No es esto exactamente lo mismo que dije (y la misma URL que publiqué)? - Hasse1987
Probablemente, el problema al intentar instalar una distribución de Linux vino con la versión de WSL incluida en su Windows LTSB. El WSL incluido el año pasado no es el mismo que se usa hoy. Si necesita WSL hoy, puede probar con versiones anteriores de las distribuciones o algunos instaladores para Linux en WSL, como WSL-Distrolauncher, WSLInstall y LxRunOffline. Una versión futura de LTSB incluirá versiones más nuevas de WSL y podrá ejecutar distribuciones actuales en ese momento. - ¿Sabes cuál es el número de versión / compilación efectivo de tu Windows LTSB? - Jaime


Respuestas: