Pregunta El arranque del cliente usando ltsp no leerá el archivo de configuración


Siguiendo las instrucciones de http://ternarybit.org/chrome-web-kiosk-guide/ excepto usar cromo en lugar de cromo Se ha configurado en una máquina virtual del servidor ubuntu en hyper-v en Windows Server 2016 y he estado usando otra máquina virtual para probar el arranque PXE. El cliente inicia en un escritorio ubuntu y solicita un nombre de usuario y contraseña (parece que funciona con el nombre de usuario y la contraseña que está en el servidor), pero se supone que debe mostrar cromo.

Para tratar de descubrir por qué no estaba recibiendo mi navegador web, agregué LDM_AUTOLOGIN = True a /var/lib/tftpboot/ltsp/i386/lts.conf (más información http://manpages.ubuntu.com/manpages/zesty/en/man5/lts.conf.5.html) y la máquina virtual de prueba todavía muestra el inicio de sesión de Ubuntu, lo que da como resultado mi suposición de que algo no está leyendo lts.conf.

Mi archivo lts.conf se ve así:

#http://wiki.ltsp.org/wiki/Configuration
LDM_AUTOLOGIN = True
#SCREEN_07 = kiosk
KIOSK_EXE = "chromium-browser"
KIOSK_OPTIONS = "--no-first-run"
RCFILE_01="/etc/init.d/profile-detect"

Me gustaría que la VM del cliente se inicie en modo kiosco y muestre el navegador web (eventualmente para mostrar una página web específica, pero puedo acceder a eso más adelante).

Cualquier ayuda será apreciada.


0


origen


Por favor tipo (o copie y pegue) su archivo conf en su pregunta (editar la pregunta). - G-Man


Respuestas: