Pregunta La búsqueda de Windows 10 no puede encontrar CUALQUIER aplicación. Incluso la calculadora [duplicar]


Esta pregunta ya tiene una respuesta aquí:

Tengo un problema con Windows 10 Enterprise N x64. Cuando presiono "Inicio" y comienzo a escribir el nombre de la aplicación, nunca lo encuentro.

Ni siquiera puedo encontrar aplicaciones como "Calculadora", "Microsoft Word" o cualquier otra. Solo muevo puntos y lo dejo funcionar durante 30 minutos sin ningún éxito.

PD. Existe la posibilidad de que esto no funcione para usted si actualizó en lugar de la instalación limpia de Windows 10. Pero siempre puede intentarlo.

Estas son mis opciones de indexación. Indexing Options


159


origen


¡Parece que no soy el único con este problema! No puedo esperar la respuesta ... - xstnc
@xstnc Publiqué mi propia respuesta (No lo puedo aceptar ahora) que pensé leyendo publicaciones relacionadas con problemas similares en versiones anteriores de Windows. Puedes darle una oportunidad. Funcionó para mí - Hooch
Al principio no pareció hacer nada por mí. No intenté un reinicio. Lo comprobaré más tarde hoy y voté si me ayudó. @Bebida alcohólica - xstnc
Como tengo muchos problemas con la búsqueda de Windows 10, publiqué esta sugerencia de característica. Si terminas aquí, es posible que quieras votar sobre él. - Jesko Hüttenhain
Descubrí que si vas a C: \ ProgramData \ Microsoft \ Windows \ Start Menu \ Programs y abres el acceso directo "Buscar", se abre la función "Buscar en todas partes" de Win 8, y allí aparecen todas las aplicaciones, por lo que tiene ser un error en la nueva interfaz de usuario de búsqueda de win 10, y no en las opciones de indexación. Solo deseo que "win + s" abra "Buscar en todas partes" en lugar de Cortana. - Augusto Barreto


Respuestas:


No tengo idea de por qué o qué he roto en el proceso. Pero aquí está lo que funcionó para mí.

  1. Ctrl + Shift + clic derecho en una parte vacía de la barra de tareas y haciendo clic en "Exit Explorer" (o elimínelo a través del Administrador de tareas si eso no funciona).

  2. Eliminar esta clave de registro

HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Explorer \ FolderTypes \ {ef87b4cb-f2ce-4785-8658-4ca6c63e38c6} \ TopViews \ {00000000-0000-0000-0000-000000000000}

  1. Comience el proceso Explorer.exe a través del Administrador de tareas.

Esta es una de las muchas respuestas publicadas aquí. Siéntase libre de probar las sugerencias de otras personas. Si combinas todas las respuestas en una, aceptaré tu respuesta.

enter image description here


Método para la actualización del creador Revisa esta responder.


95



Para mí no funciona: / - Ev0oD
Simplemente matando a Explorer y reiniciando lo hizo por mí. Instrucciones ampliadas para traer de vuelta su barra de tareas a superuser.com/a/313998/197108 - Noumenon
Esto funcionó para mí, pero ¿puedo señalar lo extraño que es - Jared Beach
No aconseje a las personas que eliminen explorer.exe si todavía está respondiendo. En vez de eso, recomiéndeles que salgan del explorador. En Windows 10, esto (aparentemente) se realiza mediante Ctrl + Shift + clic con el botón derecho en una parte vacía de la barra de tareas y haciendo clic en "Salir del explorador". Esa característica existe precisamente para este tipo de cosas. - Kevin Cathcart
Buen error ortográfico en la captura de pantalla: D - Matthew Cawley


Encontré una solución aquí: Cortana no encuentra aplicaciones de escritorio cuando las busca

Aquí está la parte relevante:

Reinstalé Cortana usando el siguiente procedimiento:

  1. Abra una ventana elevada del símbolo del sistema (presione win + X, y luego presione A)
  2. Tipo start powershell y presione enter
  3. Ejecute el comando (en una línea):

    Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    

Después de 30 segundos, el problema se resolvió en mi máquina. Increíble.


72



Funcionó muy bien para mí - Dan Revell
Lo mismo aquí, el comportamiento era diferente de OP porque el mío podía encontrar aplicaciones predeterminadas pero no las que había instalado (como Word, Excel, etc.) y que podía encontrar en la lista Todas las aplicaciones. Esto lo arregló para mí, gracias! - DannyT
Puede parecer absurdo, pero esto ayuda incluso cuando Cortana NO es compatible en tu idioma o país Solo inténtalo. - Radek Pech
+1 Esto funcionó para mí. WTF windows. ¡Reparar esto no debería tomar 2 días! - Anshul
Esta pregunta fue sobre Windows Search , No Cortana. Tengo un problema de samen, pero lo detuve y desinstalé cortana , estoy usando normail windows search ahora - Sam Nikzad


Desactivando el "Deje que las aplicaciones se ejecuten en segundo plano"alternar en el"Aplicaciones de fondo"página de la nueva configuración de privacidad de Windows hace que la búsqueda del menú de inicio se rompa, al menos en Windows 10 con la actualización del creador!

Recientemente reinstalé Windows 10 con la Actualización del creador en tres máquinas. Después de instalar Windows, mi primer paso en todas las máquinas fue hacer clic en todas las páginas debajo de Configuraciones -> Intimidad, deshabilitando cada alternar. Incluido entre estos estaba el "Deje que las aplicaciones se ejecuten en segundo plano"puesta en el Aplicaciones de fondo página.

Pronto, a partir de entonces, noté que las aplicaciones recién instaladas no aparecían en la búsqueda del menú de inicio, ya sea a través de win+S o simplemente comenzando a escribir cuando el menú de inicio tenía foco. En todas las máquinas, algunos resultados se muestran y otros faltan. Las cosas recién instaladas no se mostrarían. En uno, escribiendo google o chrom no daría nada más que la palabra completa, chrome, mostraría "ejecutar comando". En un punto, una máquina solo completaría notepady no se pudo hacer clic ni activar el resultado.

Este hilo me ayudó a aprender que la creación de un nuevo usuario administrador local en las máquinas resolvería temporalmente el problema, ¡gracias! Desafortunadamente, el problema volvería a ocurrir y entonces comencé a tratar de localizarlo cuando, precisamente, comenzó a suceder. Hice esto con un proceso que implica muchos, muchos reinicios e instalación y desinstalación repetidas 7-zip.

Me complació descubrir que mis hacks de registro que desactivan la búsqueda de Cortana y la búsqueda de Windows-store eran no responsable - fueron mi primera suposición. Hackear otras partes de Windows no rompió la búsqueda; tampoco mi script power-shell que desinstala todo el bloatware que viene con Windows 10: Facebook, Twitter, XING, Keeper, la lista continúa. (Este material también se vuelve a instalar automáticamente, repetidamente y se vuelve a instalar para nuevas cuentas de usuario).

Finalmente, rastreé el problema a esta configuración de privacidad, ¡otra cosa que es específica de la cuenta del usuario!

Mis pruebas muestran que todavía se puede deshabilitar todas las aplicaciones para que se ejecuten en segundo plano, siempre y cuando el interruptor primario esté en la parte superior de la "Aplicaciones de fondo"la página permanece En. Aquí hay una captura de pantalla de mi configuración con el trabajo de búsqueda del menú de inicio:

Working Privacy Settings

El resto de los conmutadores de privacidad se pueden desactivar en todas las demás páginas.

Y, por último, parece que si el "Deje que las aplicaciones se ejecuten en segundo plano"alternar es Apagado, encenderlo de nuevo y reiniciar parece reparar la búsqueda del menú de inicio, aunque parece tomar un tiempo antes de que los resultados vuelvan a ser 100%.

De las soluciones enumeradas en esta pregunta, solo funcionó la sugerencia de crear una nueva cuenta de usuario local y eso solo hasta que apagué esta problemática alternancia otra vez.


Si no ve el botón "ejecutar las aplicaciones en segundo plano", puede habilitarlo a través del registro. Para hacerlo;

  1. Presione la tecla del logotipo de Windows + R para abrir el diálogo de ejecución. Escriba "regedit" y luego presione enter.
  2. Navegue a la siguiente clave: HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ BackgroundAccessApplications
  3. Haga clic derecho sobre BackgroundAccessApplicationsy seleccione Nuevo -> Valor DWORD (32 bits). Nombralo GlobalUserDisabled y establecer su valor a 0.
  4. Reiniciar.

65



Gracias. Esto funcionó para mí con la actualización del Creador. - jordanbtucker
¡GRACIAS! Absoluto salvavidas. Microsoft es tan frustrante a veces. - anon58192932
¿Esto ha sido enviado para conectarse? - Marlon
Gracias un montón! +1 buena respuesta - esp por mencionar también que los ajustes de registro no fueron responsables. Yo también creé un nuevo perfil ... - Jeremy J Wong
Bueno, esta interfaz de usuario no tiene sentido. Cualquiera esperaría que un conmutador maestro se pusiera encima de varios conmutadores más específicos para controlar solo dichos conmutadores, y no una característica básica y totalmente independiente del SO. Microsoft es Microsoft, supongo. - Arno


Para aquellos que hacen su camino aquí, pero para quienes la respuesta aceptada no funciona, obtuve este tipo de aplicación buscando trabajar con los siguientes pasos:

  1. Vaya a Opciones de indexación en el Panel de control (solo puede buscar 'índice').
  2. Haga clic en el botón Modificar para obtener la ventana Ubicaciones indexadas.
  3. Expanda su disco de sistema operativo y marque las casillas de verificación para Archivos de programa y Archivos de programa (x86).

Puede tomar unos minutos para que todo comience a funcionar de la manera que espera.


23



7 y 8 parecen estar haciendo esto al incluir automáticamente C: \ Users \ <usuario> \ AppData \ Roaming \ Microsoft \ Windows \ Start Menu en las ubicaciones indexadas, y 10 no. Así que mi método, como se publicó anteriormente, es una especie de método de fuerza bruta, pero lo elegí porque a veces instalo cosas sin una opción de "Agregar al menú de inicio" (lo que hace que esta búsqueda de aplicaciones sea aún más útil). - Karim Temple
Para mí, todo estaba correcto. - Hooch
@KarimTemple - Señor, aconsejó a las personas que usen la búsqueda ("[...] solo puede buscar 'índice' [...]) en su respuesta a una pregunta, lo que explica que op no encuentra nada en la búsqueda ... jajaja - WoIIe
@Wolle ¡Buen punto! ¡Lo siento! Pude buscar opciones de indexación, así que supongo que la naturaleza de mi problema fue ligeramente diferente. - Karim Temple
Tuve este problema en una instalación de actualización de Win10 desde Win8.1 y también en otra máquina con nueva instalación de Win10. Podría buscar 'índice' como @KarimTemple encontrado. - AnneTheAgile


Cómo resolví mi problema:

El servicio Windows Search estaba deshabilitado de alguna manera, creo que lo he desactivado usando msconfig sin saber sobre las consecuencias.

Sin embargo, intenta correr services.msc y asegúrate Windows Search está habilitado y comenzó. Deberías ver el resultado de inmediato.

¡Buena suerte!


8



Esto fue lo que descubrí. La búsqueda de Windows está deshabilitada de forma predeterminada en Windows 10. - ironywrit
Este fue precisamente el problema para mí también, en una nueva instalación de Windows 10. El servicio de búsqueda de Windows estaba deshabilitado. Sin embargo, no fue culpa de Windows, sino del software "Samsung Magician" que se envía con las SSD de Samsung. Deshabilita el servicio de búsqueda de Windows como parte de sus optimizaciones. - jlh
@ironywrit: en realidad está habilitado por defecto (Automatic Start Delay). - surfasb


Tuve el mismo problema. Mi solución para esto fue ir a Opciones de indexacióneligió Avanzado, luego elige Rebuild the index. Eso lo solucionó de inmediato.


7



No me ayudó Trató esa opción. Pero tal vez funcionará para otros. Esto se parece mucho más a un problema realmente complejo. - Hooch
Esto resolvió mi problema. - Billy


Solo estoy agregando un resumen basado en mi propia experiencia.

La respuesta de Augusto funciona para mí, pero solo de manera temporal. Simplemente reinstala cortana. Ve a Powershell y escribe

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Después de un tiempo las cosas salieron como solían ser. A veces, si escribo zend, aparecerá zend studio. A veces no.

También estoy usando uno de los comentarios como otra respuesta en caso de que no funcionó para usted.

Descubrí que si vas a C:\ProgramData\Microsoft\Windows\Start Menu\Programs y abre el acceso directo "Buscar", abre la función "Buscar en todas partes" de Win 8, y allí aparecen todas las aplicaciones, por lo que tiene que ser un error en la nueva interfaz de usuario de búsqueda de win 10, y no en las opciones de indexación. Solo deseo que "win + s" abra "Buscar en todas partes" en lugar de Cortana. - Augusto Barreto, 11 de agosto a las 17:52

Eso está escrito por Augusto otra vez. AMBOS esto funciona para mí.

Hice la reconstrucción del índice y otras soluciones. Eso no funcionó o solo funcionó temporalmente.

Gracias Augusto. Creo que debería agregar mi propia respuesta para que todos sepan qué soluciones funcionan en mi caso y, probablemente, también en sus casos.


7





La cuenta de administrador local fue el problema

Estaba construyendo un Windows 10 Pro SOE basado en x64 1607 cuando me encontré con la búsqueda del menú de inicio y no encontré ninguna aplicación.

Para ser específico, como se indicó anteriormente en un par de publicaciones, pude encontrar aplicaciones preinstaladas predeterminadas pero no algo nuevo, por ejemplo. cuando instalé Adobe Acrobat Reader DC, no obtuve ningún resultado al buscar "Adobe" o "Acrobat" o "Reader".

Intenté todas las sugerencias anteriores, pero lamentablemente nada funcionó.

Me di cuenta de que el problema era específico de la cuenta de administrador local incorporada. Cuando probé lo mismo con múltiples usuarios nuevos en el sistema, mis búsquedas funcionaban como se esperaba. Sospecho que está relacionado con la forma en que algunas aplicaciones UWP (calc, edge) no pueden ejecutarse bajo la cuenta de administrador local, tal vez Cortana / Windows Search no funciona para el administrador local.


3



Sí. Igual que aquí. Pero, ¿cómo resolver esto? - Leonel
El problema es Cortana. Si no está activado o no funciona, la búsqueda no funcionará. En mi caso, no estaba activo porque mi Windows está en inglés, pero mi configuración de ubicación era para Brasil. Una vez que lo cambié a Estados Unidos, todo funcionó. - Leonel
Creando una nueva cuenta de usuario local hace resolver el problema, pero la razón es porque la nueva cuenta de usuario tiene el valor predeterminado "Intimidad"Configuración. He identificado cuál de estos está relacionado con el problema: vea mi nueva respuesta. (Incluso con la nueva cuenta de usuario, desactivar la configuración ofensiva hará que el problema vuelva a ocurrir). - Xharlie