Pregunta Libcurl no se puede usar en mac os x


Estoy ejecutando el comando configure para instalar un paquete de software en particular, pero falla cuando alcanza el requisito de libcurl.

Este es el resultado que da:

checking for the version of libcurl... 7.34.0
checking for libcurl >= version 7.15.2... yes
checking whether libcurl is usable... no
configure: error: Missing required libcurl >= 7.15.2

Entonces, tengo instalada la versión 7.34, que es mayor que la 7.15.2 requerida, pero por alguna razón no es utilizable ... (línea 3).

curl --version produce lo siguiente:

> curl --version
curl 7.34.0 (x86_64-apple-darwin13.0.0) libcurl/7.34.0 OpenSSL/1.0.1e zlib/1.2.8 libidn/1.26
Protocols: dict file ftp ftps gopher http https imap imaps pop3 pop3s rtsp smtp smtps telnet tftp 
Features: IDN IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP 

¿Alguna idea de lo que está pasando aquí?


0


origen


compruebe config.log después de que la ejecución falló, le mostrará la prueba de configuración intentada que falló ... - Daniel Stenberg
Una opción es instalar libcurl usando homebrew (brew.sh) o macports (macports.org), luego enlaza con la versión más nueva de libcurl. OS / X envía bastante viejo libcurl, por lo que esta podría ser la única opción. - Sami Laine


Respuestas: