Pregunta Construyendo contra un glibc antiguo


¿Es posible construir glibc / gcc / binutils en el combo de versión de, por ejemplo, 2.4 / 4.6 / 2.22 (o alguna versión posterior de GCC utilizada por la distribución de Linux más antigua / 'más estable' todavía)?

Me gustaría crear compiladores cruzados independientes para MinGW y hacer que funcionen en más de glibc 2.14 (mi Fedora actual), en este orden:

  1. construir glibc<old version> con el compilador de distribución estándar
  2. construir nuevos binutils / gcc usando esta versión antigua de glibc
  3. compilar compiladores cruzados utilizando la nueva combinación de herramientas.

0


origen


¿Qué hay de instalar cada una de estas distribuciones en una VM propia? Después de compilar su proyecto en la máquina virtual, puede probarlo allí también. - ott--
El "otro" sistema no es uno que quiera usar para esto. Probablemente tampoco funcionará con mi nuevo hardware :( - rubenvb


Respuestas: