Pregunta Conexión a Internet con un módem USB 3G


Estoy tratando de establecer una conexión a Internet con wvdial. Todo está bien pero el problema es que no puedo hacer ping, por ejemplo google.ca o su dirección IP.

Aquí está el resultado de la wvdial mando:

WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,"IP","internet.com,wapuser1,wap"
AT+CGDCONT=1,"IP","internet.com,wapuser1,wap"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT 21096000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sat Jan  1 05:11:06 2000
--> Pid of pppd: 3297
--> Using interface ppp0
--> pppd: ([07][08]@[07][08][08][07][08]
--> pppd: ([07][08]@[07][08][08][07][08]
--> pppd: ([07][08]@[07][08][08][07][08]
--> pppd: ([07][08]@[07][08][08][07][08]
--> local  IP address 172.19.154.90
--> pppd: ([07][08]@[07][08][08][07][08]
--> remote IP address 10.0.0.1
--> pppd: ([07][08]@[07][08][08][07][08]
--> primary   DNS address 64.71.255.198
--> pppd: ([07][08]@[07][08][08][07][08]
--> secondary DNS address 64.71.255.253
--> pppd: ([07][08]@[07][08][08][07][08]

Como puede ver, claramente puedo obtener una IP y escribir ifconfig ppp0 muestra esto:

ppp0      Link encap:Point-to-Point Protocol
          inet addr:172.19.27.135  P-t-P:10.0.0.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:5 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:74 (74.0 B)  TX bytes:107 (107.0 B)

Pero no puedo hacer ping a nada.

Entonces sé que no es una cuestión de /etc/resolv.conf.

Aquí está el contenido de mi wvdial.conf:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","internet.com,wapuser1,wap"
Modem Type = USB Modem
ISDN = 0
New PPPD = yes
Phone = *99#
Modem = /dev/ttyACM0
Username = wapuser1
Password = wap
Baud = 460800
Stupid Mode = 1

¿Cómo puedo hacer que esta configuración funcione?

ip addr show:

9: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 3
link/ppp inet 172.16.29.33 peer 10.0.0.1/32 scope global ppp0

ip route show:

default dev ppp0 scope link 10.0.0.1 dev ppp0 proto kernel scope link src 172.16.61.19

0


origen


Es probable que también deba incluir la salida de ip addr show y ip route show. Si ping(1) no funciona, ¿qué hay de los tipos de paquetes que no son ICMP? UDP o TCP? - sarnold
9: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast st ate UNKNOWN qlen 3 link/ppp inet 172.16.29.33 peer 10.0.0.1/32 scope global ppp0 and ip route show default dev ppp0 scope link 10.0.0.1 dev ppp0 proto kernel scope link src 172.16.61.19 - gimpycpu


Respuestas:


Estaba enfrentando el mismo problema ayer. Lo tengo para trabajar hoy. Verifique la respuesta a esta pregunta.

https://raspberrypi.stackexchange.com/questions/62417/connected-to-internet-on-ppp0-in-raspberry-pi-3-but-commands-like-ping-curl-not

Debe verificar si puede conectarse a internet a través de la interfaz ppp0. Ingrese el siguiente comando y verifique la salida ping -I ppp0 google.com. Si puedes hacer ping, entonces tu dispositivo está conectado a internet.

Entonces, puedes ejecutar el comando sudo route add default dev ppp0 para ganar acceso a internet


0