Pregunta Pasando por alto el enrutador de Bell Canada provisto con su servicio FIBE


Acabo de recibir una conexión a Internet de fibra, Fibe 50-50 de Bell Canada, en sustitución de una conexión ADSL vieja, lenta y no confiable.

Tengo una oficina en casa y utilizo una VPN, reserva de DHCP, un servicio DDNS, etc. Todas estas características no son compatibles con el enrutador suministrado por Bell. Quiero pasar por alto su Home Hub 2000 y usar mi propio enrutador.

Encontré en la web que el ONT (terminal de red óptica, el dispositivo que recibe la fibra óptica en un lado y que da un puerto Ethernet WAN RJ-45 en el otro) funciona utilizando el protocolo PPPoE al igual que un antiguo módem ADSL.

Así que traté de conectar el puerto WAN de mi enrutador con la identificación de usuario y la contraseña adecuadas. Sin suerte. No funcionó. Puede haber una configuración personalizada oculta en el enrutador Bell Home Hub 2000.

¿Cómo me puedo conectar a Fibe con un enrutador de mi elección?


4


origen




Respuestas:


No estoy seguro si la pregunta todavía es relevante, pero aún así quería compartir el resultado de mi investigación.

Acabo de cambiar de un Cable ISP a Bell Fibe, tanto para TV como para Internet. Bell todavía no tiene fibra en casa en mi área, por lo que todavía es una conexión de tipo DSL. Bell proporcionó un módem / enrutador HUB2000 integrado. el dispositivo es muy fácil de usar, pero todas las características avanzadas de la red están bloqueadas ... como se esperaba.

Tenía toda mi red ya configurada como con mi proveedor de Internet anterior (Videotron solo proporcionaba un cablemódem) y quería mantener la misma configuración (cortafuegos, IP, etc.).

Entonces esto es lo que hice:

  1. El receptor de TV está conectado a través de un cable de red al puerto LAN HUB2000 (según la configuración original de Bell)
  2. HUB 2000 está conectado a la línea telefónica para actuar como un módem DSL (según la configuración original)
  3. El puerto WAN de mi enrutador MikroTik está conectado a uno de los puertos LAN del HUB 2000. Ahora este es el truco, en mi configuración Mikrotik WAN, en lugar de usar el cliente DHCP, estoy usando un cliente PPPoE con las credenciales proporcionadas por Bell para mi cuenta de Internet (usuario y contraseña de b1xxxx).

Con esta configuración, mi enrutador obtiene una IP externa de Bell, por lo que HUB2000 actúa como un puente.

El siguiente paso, deshabilité el WIFI en HUB2000 y volví a usar el otro punto de acceso que tenía dentro de mi red local. para que todos los clientes estén detrás del mismo firewall.

Lo anterior no afectó al receptor de TV y no hubo necesidad de cambiar el HUB2000 o el receptor de TV. También he dejado que DHCP se ejecute en el HUB2000.

Resumen:

  1. No tuve que hacer ningún cambio en el receptor de TV o el enrutador (HUB2000)
  2. No perdí WIFI en HUB2000, todavía funcionaba y pude conectarme a internet a través de WIFI
  3. tan pronto como me conecté con el cliente PPPoE, el enrutador de mi casa desapareció del alquiler DHCP de HUB2000 porque ya no recibía una IP del servidor HUB2000 DHCP
  4. HUB2000 permaneció conectado a internet a través de su propia conexión PPPoE. así que ahora tenía 3 IP externas diferentes asignadas a:

    1.TV

    2.WAN puerto de HUB2000

    3.WAN puerto de mi Mikrotik

  5. MikroTik no era visible desde HUB2000 y viceversa.

  6. seguramente tiene que ejecutar FW, servidor DHCP y cualquier otra cosa que necesite en su enrutador ya que HUB2000 ya no está en su camino.

Espero que esto ayude: +)


4





Después de un pequeño ataque de cables y algo de pérdida de cabello, descubrí por qué los enrutadores comunes no pueden eludir el enrutador Sagemcom Home Hub 2000 provisto por Bell, que se conecta directamente a Bell a través del ONT usando PPPoE. Es porque el enrutador Bell se conecta a los servidores de Bell a través de un 802.1Q VLAN! ID de VLAN #35, para ser exacto.

Entonces, para hacer esto usted mismo:

  • Conecte su computadora / enrutador directamente al puerto de Ethernet del ONT.
  • Utilizar 802.1Q VLAN 35.
  • Use PPPoE.

La mayoría de los enrutadores civiles (incluido mi Linksys EA6300v1) no son compatibles con 802.1Q, por lo que todavía estás atornillado allí, a menos que instales firmware personalizado, obtenga un enrutador mejor o conecte el ONT directamente a una computadora. (Alternativamente, si el enrutador que quiere usar no es compatible con 802.1Q, puede hacer el bit 802.1Q usando un interruptor administrado. Ver comentario de grawity.) Incluso si su enrutador es compatible con 802.1Q, las instrucciones de configuración variarán de enrutador a enrutador, por lo que no puedo ayudarlo más, pero con esas tres piezas de información y el hardware que admite 802.1Q y PPPoE, deberías poder hacerlo.

En Linux

Así es como lo configuraste en Linux. Nuevamente, debe tener su computadora linux (/ enrutador) conectada directamente al puerto ethernet de su ONT. Necesitarás el ip comando (provisto por iproute2, en caso de que todavía no lo tenga) y rp-pppoe. Reemplazar enp3s0 con su nombre de interfaz real. Todos los comandos deben ejecutarse como root.

Primero tienes que hacer la VLAN:

# ip link add link enp3s0 name enp3s0.35 type vlan id 35

Eso crea una nueva interfaz de red virtual llamada enp3s0.35. Todo el tráfico enviado en esa interfaz se encapsulará en VLAN id 35 antes de enviarse a enp3s0. Lo que sucede en realidad es básicamente que el número 35 en realidad se agregará a cada paquete antes de ser enviado. Sin este número adicional, Bell simplemente te ignorará.

Ahora, necesita configurar rp-pppoe. Modificar /etc/ppp/pppoe.conf, cambiando las siguientes líneas:

ETH=enp3s0.35
USER=bxxxxxxx@bellnet.ca

Ahora, modifica /etc/ppp/pap-secrets, agregando la siguiente línea:

bxxxxxxx@bellnet.ca * your_ppp_password

Ahora puedes comenzar a usar pppoe pppoe-start. Si funciona, el comando debería regresar después de unos segundos. También puedes verificar usando ip a. Se debe hacer una nueva interfaz llamada ppp0 con tu IP global. El comando para detenerlo es pppoe-stop. Aquí hay un ejemplo de inicio y detención exitosos:

[user@host ~]% sudo pppoe-start
. Connected!
[user@host ~]% ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:21:70:71:82:b9 brd ff:ff:ff:ff:ff:ff
3: enp3s0.35@enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 00:21:70:71:82:b9 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::221:70ff:fe71:82b9/64 scope link
       valid_lft forever preferred_lft forever
5: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group default qlen 3
    link/ppp
    inet 70.27.234.242 peer 10.11.2.201/32 scope global ppp0
       valid_lft forever preferred_lft forever
[user@host ~]% sudo pppoe-stop
Killing pppd (4102)
Killing pppoe-connect (4080)

El método de ejecutar el ip link y pppoe-start los comandos automáticamente en el arranque variarán con su distribución. De nuevo, no puedo ayudarte más aquí. Las distribuciones de enrutadores y cortafuegos deberían tener un buen soporte para todas estas cosas. systemd-networkd admite configuraciones 802.1Q en el arranque. Y es muy probable que el paquete rp-pppoe de su distribución tenga una forma de iniciarlo también de manera automática, pero puede que necesite modificarlo, prohibiéndole comenzar hasta después de que la interfaz 802.1Q esté activa.

Una vez que tiene 802.1Q y PPPoE que se inician automáticamente al arrancar, ahora es seguro configurar su enrutador Bell encendiéndose. Si lo hace, hágalo en un área bien ventilada y envíeme una foto. No encienda el ONT.

Ronda de bonificación: openwrt / ea6300v1

Como se mencionó anteriormente, openwrt no tiene problemas con configuraciones extrañas; eso es algo así como realmente. Incluso si su enrutador no es compatible con 802.1Q, hay muchas posibilidades de que lo haga después de haber instalado openwrt. Este es el /etc/config/network para mi ea6300v1:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fc00::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.35'  # <----
        option proto 'pppoe'  # <----
        option username 'bxxxxxxx@bellnet.ca'  # <----
        option password 'your ppp passphrase'  # <----

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '35'  # <----
        option ports '4t 5t'  # <----

pongo # <---- al lado de todas las líneas que tuve que modificar para que Bell Fiber funcione. En el último agregué un t al puerto 4, indicando al interruptor que marque todo lo que sale del puerto 4 (el puerto WAN) con las etiquetas 802.1Q. Así que eso t se supone que está allí. No es un error

El proceso (probablemente) será muy similar para su enrutador de grado de consumidor. Tenga en cuenta que los diferentes enrutadores usan diferentes arquitecturas de conmutación y numeraciones de puertos, por lo que puede que tenga que pensar un poco en ello. Por ejemplo, tal vez su puerto WAN sea el puerto 0, no el puerto 4. Por lo tanto, definitivamente no copie y pegue a menos que por alguna casual coincidencia su enrutador sea realmente ea6300v1. Creo en ti.


3



Con la edición sugerida a la pregunta: 1) Las modificaciones sugeridas deben ser revisadas por hasta otros tres usuarios. Por lo tanto, para perder innecesariamente su tiempo, tiene que ser sustancial. Si bien es técnicamente correcto, su edición es trivial y la pregunta es claramente comprensible sin ella. Tiene razón en que el mensaje enlatado podría estar redactado un poco mejor, pero es el mejor disponible. 2) La otra cosa que debes hacer cuando sugieres una edición es corregir todas los problemas con la publicación Hay varias instancias de capitalizaciones iniciales injustificadas ... - robinCTS
... ("Sólo", "Casa ", "Módem", "Contraseña", "Cómo"), múltiples capitalizaciones incorrectas de empresas / acrónimos / etc. ("CAMPANA", "FIBE", "PPPOE", "IDENTIDAD DE USUARIO"), un error ("agudeza"), además de la gramática necesita una revisión masiva. Y luego está la cuestión de que la publicación es un bloque de texto sin paragraghs. Si tuviera que corregir todos esos, su edición sería aprobada. Tenga en cuenta que una vez que llegue a 2000+ reputación, sus ediciones tendrán efecto automáticamente y usted podrá hacer tantas correcciones como sea posible sin penalización. (Sin embargo, sería bueno si pudiera solucionar todos los problemas ;-)) ... - robinCTS
... Ver mi edición a la pregunta para una idea de lo que se requeriría en este caso. (Los párrafos, la gramática / ortografía / puctuación y los CAPTURAS MÁS ALTAS son los temas más importantes que deben corregirse en ese orden. No se le debe penalizar por elementos faltantes como "PPPoE", aunque si conoce los errores correctos en mayúsculas, sería bueno si pudieras arreglarlas también.) PD: Acabo de ver tu edición sugerida anterior. Lo principal que te perdiste haciendo ese tiempo fue agregar los párrafos. Eso mejora la legibilidad de una pregunta mucho. Agregue a eso algunos errores gramaticales perdidos y ... - robinCTS
... un par de críticos duros ¯ \ _ (ツ) _ / ¯ Viniendo de la forma Stack Overflow como un editor experimentado y crítico, encontré que los revisores aquí son bastante duros. Incluso la edición que he hecho a la pregunta habría tenido la oportunidad de ser rechazada. Como se olvidó de agregar los párrafos, su primer intento no tuvo ninguna posibilidad. Si un sustancial la edición sugerida de la tuya es rechazada y lo sientes con fuerza al respecto, puedes publicar una meta pregunta sobre ella o publicar un comentario dirigido a la OP. El OP puede anular unilateralmente una edición sugerida rechazada. - robinCTS
Si el enrutador deseado no es compatible con 802.1Q, compre un interruptor que sí lo haga. Los switches administrados de grado "Small Business" con soporte de VLAN pueden ser bastante económicos: configure un 35 puerto etiquetado para el ONT, 35 sin etiquetar para la entrada "WAN" del enrutador y el resto (sin etiquetar 1) para su LAN, de modo que no realmente se desperdiciara - grawity


Recibí una parte de la respuesta hablando con alguien técnico de Bell que no está en la asistencia técnica del cliente. ¡Tuve mucha suerte! Es extremadamente raro hablar con alguien muy técnico en BELL Canadá. Encontré el resto por suposición acertada y aquí está toda la receta. Conecte el puerto FTTU RJ45 al puerto BELL Home 2000 WAN. Configure el puerto BELL 2000 FIBER con la identificación 1B y la contraseña que BELL le dio (como se recomienda). Luego, conecte uno de los 4 puertos LAN del enrutador BELL 2000 a su propio puerto WAN del enrutador. Configure su enrutador con WAN como PPPOE con exactamente la misma ID de 1B y la contraseña que ingresó en BELL 2000. Deje todas las demás configuraciones de BELL 2000 en los valores predeterminados. (DHCP habilitado ==> muy importante para la TV). Esto suena loco, pero de esta manera, el BELL 2000 actúa como un passthrough y cualquier solicitud de DHCP en su LAN es capturada por su propio enrutador.

Ahora la parte más difícil es hacer funcionar el terminal de TV desde el puerto RJ-45. Si lo conecto a mi enrutador, no funciona en absoluto. La terminal de TV se queja de no ver "señal de TV". El truco que encontré es conectar el terminal de TV a un segundo puerto LAN BELL 2000. Lo más extraño es que mató completamente la red WIFI de mi enrutador. Supongo que de alguna manera despertó algo en el BELL 2000 y aparecieron los conflictos. La última solución es desactivar la interfaz WELL de BELL 2000, aunque tenía un SSID diferente al mío.
Así es como obtuve una red local completa conectada a internet con un enrutador avanzado con TV y conexión de internet FIBE.

Una nota interesante es que el enrutador BELL 2000 tiene 192.168.2.1 como dirección IP. Mi propio enrutador también tiene la misma dirección y parece no entrar en conflicto. De hecho, mi enrutador no ve el BELL TV en la red local (y eso está bien conmigo). Parece que BELL 2000 simplemente pasa cualquier paquete de datos directamente hacia y desde mi enrutador y cualquier TV IP directamente al terminal de TV y lo considera como dos subredes diferentes.

Espero que ayude a otros.


1



El enrutador ahora actúa solo como un dispositivo de capa 2 y no hace ningún enrutamiento real. - David Schwartz