Pregunta Problema con la red después del ataque de malware


Estoy tratando de ayudar a algunos amigos con una máquina Win XP. Me deshice del malware usando Malware Bytes y HiJackThis. Pero ahora ellos (I) tienen otro problema.

Cuando la computadora arranca en Windows parece estar bien. Cuando inicio Internet Explorer, la ventana del navegador se abre bien, pero no ocurre nada por minuto o dos. Después de los dos minutos de espera, el ícono de red aparece en la barra de tareas al lado del reloj, y luego todo funciona.

La computadora está conectada a internet usando un adaptador Ethernet.

Miré el Rvent Log y encontré un error de Perfnet con evento 2004

<Provider Name="PerfNet" />  
<EventID Qualifiers="49152">2004</EventID>  
<Level>2</Level>  
<Task>0</Task>  
<Keywords>0x80000000000000</Keywords> 

Lo que he intentado hasta ahora: 

  • En el administrador de dispositivos, desinstalé el adaptador Ethernet y lo instalé nuevamente.
  • He desinstalado e instalado el servicio de Compartir archivos e impresoras de Windows.
  • He verificado que los servicios del servidor y de la estación de trabajo están iniciados.

¿Qué debería hacer después?


2


origen




Respuestas:


Personalmente, sugiero borrar las particiones y volver a instalarlas. Podría pasar horas intentando limpiar esto, momento en el que podría haber reinstalado el sistema desde cero.

La reinstalación es la única manera garantizada de limpiar el malware del sistema también.

Eduque a su amigo para que no use derechos de administrador en el futuro, a menos, por supuesto, que se requieran derechos de administrador, p. al instalar el software.


2



Gracias por la respuesta. Un formato y una reinstalación podrían ser la solución final de la solución, pero odiaría hacerlo, ya que la gente siempre olvida respaldar algo. - Cruelio


Ejecute un escaneo MalWareBytes (escaneo completo). Puede recoger algunos problemas de registro.


1





¿Has probado con otro navegador como Firefox u Opera? ¿O cualquier otro software en red? Si no tiene uno, puede usar ping www.google.com en un símbolo del sistema

Si solo está relacionado con IE, podrías intentar entrar Tools > Manage Addons para deshabilitar todo sospechoso. Y esta herramienta Arreglar IE podría ayudar también

Si se trata de un problema de toda la red:

En un símbolo del sistema (ejecutado como administrador):

netsh int ip reset intipreset.log
  Restablezca la pila TCP / IP = reinicie / vuelva a escribir las siguientes claves de registro relacionadas con TCP / IP:

    * SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\
    * SYSTEM\CurrentControlSet\Services\DHCP\Parameters\

Es posible que deba volver a configurar su configuración TCP / IP después de eso

netsh winsock reset
Repair winsock Elimina todos los LSP de Winsock (proveedores de servicios en capas) instalados previamente, incluido el posible LSP defectuoso que causa la pérdida de la transmisión de los paquetes de red.

Por lo tanto, es posible que sea necesario volver a instalar todos los LSP instalados previamente (antivirus / firewall)

interfaz netsh restablecer todo
Restablecer todas las interfaces: 6to4, HTTPSTunnel, ipv4, ipv6, isatap, portproxy, tcp, teredo

No sé exactamente a qué te arriesgas a hacerlo (no mucho, creo, excepto la reinstalación / reconfiguración del software relacionado con la red y los parámetros de Windows ...)


1



Gracias. Daré tus sugerencias hace cuando me acerque a la computadora otra vez - Cruelio


has intentado conectarte a cualquier cosa sin usar IE.
por ejemplo, abrir un símbolo del sistema y hacer ping en www.google.com o incluso solo en el enrutador para comenzar.
Aunque tiendo a coincidir con el consenso, si se trata de un attck de malware particularmente desagradable, a veces es mejor hacer copias de seguridad de los datos y realizar una instalación limpia. a veces puede ser una bendición (sé que esto suena extraño, pero puedes volver a evaluar totalmente todo lo que usas y lo que necesitas no necesita. Re-diseña las particiones de la unidad, etc.)


1



He tratado de abrir las perspectivas expresas, pero simplemente me presento hasta que he esperado uno o dos minutos - Cruelio


Gracias por todas sus ideas, sin embargo, mi amigo me llamó la otra noche para decirme que la computadora funciona perfectamente ahora. Afirmó que no había cambiado nada, lo que lo hacía aún más extraño. Pero problema resuelto Otra vez, gracias por tu tiempo


1





puede haber hecho algo en la pila TCP / IP, puede valer la pena ir al símbolo del sistema y escribir lo siguiente:

NETSH INT IP RESET

NETSH INT WINSOCK RESET

Por último, usaría Microsoft / Sysinternals Autoruns y simplemente verifique si hay entradas incorrectas.

Sin ver la máquina, es difícil realmente ayudar, pero has probado la mayoría de las cosas que hubiera hecho. Después de un ataque de virus, es difícil saber qué es lo que aún se ve afectado y, a veces, una reinstalación es lo mejor.

Además, considere leer esta guía.


1