Pregunta Complemento de Firefox no compatible


Hay un complemento de Firefox que no es compatible con la última versión instalada en mi computadora. Sé que hay una forma de usar esto editando el archivo xpi, pero ni siquiera puedo descargar los archivos xpi del sitio de complemento de mozilla (el botón "obtener complemento" está deshabilitado)

¿Puede alguien ayudarme aquí?

Editar: Esto por ejemplo - https://addons.mozilla.org/en-US/firefox/addon/5462 


2


origen


¿Puedes vincular el complemento? Si es así, podría encontrar un enlace que pueda pegar en IE o Wget para descargarlo ... - Mokubai♦


Respuestas:


Utilizo las herramientas Nightly Tester, en lugar de ajustar el archivo XPI: https://addons.mozilla.org/en-US/firefox/addon/6543?src=api

Esto le permite marcar un complemento como compatible (algo así), que es más o menos una necesidad para los probadores de construcción nocturnos. Deberías usarlo con precaución, por supuesto.


4



No lo use en la barra lateral todo en uno. Realmente no es compatible con 3.6 y romperá por completo el diseño de su navegador. - Macha
Vea mi respuesta sobre Addon Compatibility Reporter. El desarrollador de Nightly Tester Tools dice: "La corrección avanzada de compatibilidad de extensiones se ha eliminado comenzando con Nightly Tester Tools 2.5, en su lugar hay una casilla para deshabilitar la compatibilidad de extensiones para todos los complementos. Se recomienda a los usuarios instalar Addon Compatibility Reporter, que hace lo mismo pero también le permite informar sobre la compatibilidad con los autores de extensiones ". - Nicolas Raoul


Intenta desplazarte hacia abajo por la página del complemento hasta la parte inferior, hay un enlace llamado "versiones anteriores". Si hace clic en este enlace, accederá a una página que le permite descargar todas las versiones más la última.


2



Ya hice +1 en. Confirmado en mi copia de Firefox, la página principal dice "No compatible" y se niega a instalar, pero desplazarse al final de la página y seleccionar "Versiones anteriores" le permite intentar instalar tanto la versión experimental como la actual. - Mokubai♦


Simplemente puede establecer el valor de extensions.checkCompatibility a falso (es un sobre: ​​config preferencia).


1





Alguien publicó un enlace a la versión 0.2.0 en los comentarios para el complemento ... Bosskey

http://ftp.mozest.com/addons/extensions/boss_key/boss_key-0.2.0-fx+fl+ns+tb-windows.xpi

0





He hecho esto antes. Tiene el potencial de romper cosas si el complemento no es realmente compatible, pero funciona bien la mayor parte del tiempo.

  1. Descargue e instale 7zip
  2. Haga clic derecho en el archivo .xpi, y elija 7zip-> abrir archivo
  3. Haga clic derecho en install.rdf, y elija editar
  4. Encuentra este código: <!-- firefox --> <em:minVersion>1.5</em:minVersion> <em:maxVersion>3.*</em:maxVersion>
  5. Modifique la maxversion para satisfacer sus necesidades
  6. Guarda el archivo. Debe ser actualizado dentro del archivo automáticamente.
  7. Cierre el bloc de notas y 7zip. Abra el archivo .xpi en firefox. ¡Espero que se instale!

0





Un resumen de las respuestas, con un poco más:

Primero necesita configurar su Firefox para que acepte la extensión "desactualizada": use el más simple Herramientas de prueba nocturna (crédito MetalMikester) o el Kit de herramientas de MR Tech con funciones extendidas (me gusta el botón desplegable de extensiones y algunos otros) (crédito: harrymc) O, como dijiste, puedes editar manualmente el archivo xpi (crédito: nhinkle) pero es más fastidioso

A continuación (y más específico para su pregunta) debe evitar la protección del sitio: use la "versión anterior" en la parte inferior de la página (crédito: CGA) o crear una cuenta mozilla, tendrá un enlace "ignorar verificación de versión" en el botón (acredíteme)


0





Golpea el Todas las versiones link en el fondo. Marque la casilla para instalar el complemento experimental. El botón Agregar a Firefox debe ir de gris a verde. Ahora haga clic derecho en el botón y seleccione Guardar enlace como. Ahora puede hackearlo para que funcione con su versión si es necesario y luego arrastre el XPI actualizado en el cuadro de complementos debajo de la sección Extensiones.


0





Ahora hay una mejor manera de hacer esto: usar el Reportero de compatibilidad de complementos, una extensión desarrollada por Mozilla. Además de permitir que se ejecute cualquier extensión, te permite opinar sobre si funciona o no.

Add-on Compatibility Reporter

Ayuda a Mozilla a asegurarte de que tu favorito   complementos se actualizan para próximos   Lanzamientos de Firefox al usar esto   extensión para informar si todavía   trabajar o están teniendo algunos problemas con   lanzamientos alfa y beta.


0





El complemento muy útil MR Tech Toolkit :

Proporciona las herramientas necesarias para instalar   y administrar extensiones y temas   localmente y toneladas de otras características.

Esta extensión proporciona   soporte de instalación de extensión múltiple,   Hackear capacidades a la   Ventanas de Extension / Theme Manager,   características para encontrar y solucionar problemas   Extensiones / Temas Build, GUID y   Información del perfil.

image


0